当前位置:首页 > 问答

MACD四次背离选股公式

我来帮TA回答

求通达信15分钟周期MACD底背离的选股公式

用日线背离的就可以了。

谁能帮我编个macd底背离的选股公式,不盛感激!

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
DIFF:=SUM(MA1-MA2,0);
SUMMACD:=SUM(MACD,0);
W1:=BARSLAST(CROSS(MA2,MA1))+1;
W2:=BARSLAST(CROSS(MA1,MA2))+1;
W3:=BARSLAST(CROSS(MACD,0))+1;
W4:=BARSLAST(CROSS(-MACD,0))+1;

趋势力度:IF(K,SUMMACD-REF(SUMMACD,MIN(W3,W4)),DIFF-REF(DIFF,MIN(W1,W2)));
趋势平均力度:趋势力度/IF(K,(MIN(W3,W4)+1)/20,(MIN(W1,W2)+1)/20),COLORSTICK;
MAX趋势平均力度:HHV(趋势平均力度,34);
MIN趋势平均力度:LLV(趋势平均力度,34);
--------------------------------------------------------------------------------------------------------------------------------------------
K值可调,调成“0”是通过均线缠绕面积判断背驰
调成“1”是通过macd面积判断背驰。
白线为均线(或macd )到目前为止的面积,白线的拐点(即某一段的最大值(绝对值))是均线或macd面积。如果K调成1,红绿柱为凭据趋势力度。

此指标不是选股指标,是个副图指标,因为选股指标需要判断前后面积的大小,难度极大,不易做出,目前还没发现有人能写出来。

求通达信日线MACD底背离选股公式

A1:=BARSLAST(REF(CROSS(MACD.DIF,MACD.DEA),1));
MACD底背:REF(C,A1+1)>C AND REF(MACD.DIF,A1+1)<MACD.DIF AND CROSS(MACD.DIF,MACD.DEA);

(以前次金叉股价与现在金叉股价相比)

求高手,编写MACD指标背离时的选股公式

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
LLV(L,2)<=LLV(L,10)
AND
DIF>REF(DIF,1);
说明:我简单测试了一下,本公式选的股可以超过A股均涨幅,是一个不错的选股器。但选出的股太多,有时上千个,有时几十个,这里我做了一个限制股数量的公式可以搭配使用。但不能在这里公布。因为一个好公式大家都用它来赚钱,是赚不到钱的,联系我后发给你。

通达信周线macd底背离盘中预警选股公式

你还在我十年前水平上

通信达MACD顶底背离选股公式

学这些没用的