当前位置:首页 >  问答

通达信主力发力指标

我来帮TA回答

谁有通达信中线主力资金指标公式

N:=24;
VAR1:= EMA(EMA(CLOSE,13),13);
控盘指数: (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,POINTDOT,COLORFFCCCC;
STICKLINE(控盘指数<0,控盘指数,0,2,0),COLORGRAY;
无庄控盘: 控盘指数<0,LINETHICK0,COLORGRAY;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数<3,控盘指数,0,2,1),COLORRED;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数>3,控盘指数,0,2,1),COLORRED;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>3,控盘指数,3,4,1),COLORFF00FF;
主力控盘: 控盘指数>REF(控盘指数,1) AND 控盘指数>0,LINETHICK0,COLORRED;
STICKLINE(控盘指数<REF(控盘指数,1) AND 控盘指数>0,控盘指数,0,2,0),COLOR00FF00;
控盘减弱: 控盘指数<REF(控盘指数,1) AND 控盘指数>0,LINETHICK0,COLOR00FF00;
VARA:= EMA(0.667*REF(控盘指数,1)+0.333*控盘指数,2);
STICKLINE(控盘指数>VARA,控盘指数,VARA,2,0),COLORRED;
B2:= 控盘指数>VARA;
准备: B2>REF(B2,1) AND 控盘指数<(-2),COLORYELLOW;
DRAWTEXT(准备,3,'准备'),COLORYELLOW;
B1:= (控盘指数>REF(控盘指数,1) AND 控盘指数>0)=1;
开始控盘: B1>REF(B1,1),COLORMAGENTA,LINETHICK3;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(X,13);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWICON(FILTER(买=1,5),L*0.11,1);
DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORWHITE,LINETHICK1;
DEA:EMA(DIFF,9),COLORYELLOW,LINETHICK1;
MACD:2*(DIFF-DEA), COLORSTICK;
MACD1:=2*(DIFF-DEA),COLORRED,NODRAW;
MACD2:=EMA(MACD1,3),COLORCYAN,NODRAW;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORYELLOW;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORGREEN;
S1:=MACD<0;
S2:= (MACD>=0);
S3:=BARSLAST(CROSS(DIFF,DEA));
S4:=REF(S3,S3+1);
S5:=DEA>REF(DEA,S4);
S6:=DEA;
上成立:=CROSS(DIFF,DEA) AND S5;
下成立:=CROSS(DIFF,DEA) AND S6;
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
变盘:CROSS(L1,L2) AND L5,NODRAW,COLORD6FF9C;
STICKLINE(变盘,5,0,0,1),COLORD6FF9C;
LS:=IF(DIFF>DEA AND DIFF>0,1,0);
加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);
XG1:CROSS(MACD1,MACD2) AND MACD1<0,NODRAW;
XG2:CROSS(DIFF,DEA),NODRAW;
M1:=MACD>REF(MACD,1) AND DIFF<DEA;
绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,NODRAW;
DRAWTEXT(绿柱短了,MACD,'买点来了');
DIFL:=EMA(V,12)-EMA(V,26);
DIF:=EMA(C,12)-EMA(C,26);
BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
四天: REF(BL,3)=1 AND REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
三天:REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
{VERTLINE(上成立,3),COLORYELLOW;
VERTLINE(下成立,3),COLORRED;}
IF(DIFF>DEA,DIFF,DRAWNULL),COLORFF11CC,LINETHICK1;
IF(DIFF>DEA AND DIFF<0,DIFF,DRAWNULL),COLORRED,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DRAWTEXT(FILTER(D>80,6),H*1.018,'D>80');
DRAWTEXT(FILTER(CROSS(K,D) AND D<26,6),H*0.95,'KD低位金叉'),COLORFFCCCC;
STICKLINE(FILTER(CROSS(K,D) AND D<26,6),H*0.97,H*0.95,4,0),COLORFFCCCC;
DIFFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEAF :=EMA(DIFFF,9);
MACDD:=2*(DIFFF-DEAF);
DRAWTEXT(FILTER(CROSS(DIFFF,DEAF) AND DEAF<0,6),L-0.02,'MACD低位金叉'),COLORRED;
STICKLINE(FILTER(CROSS(DIFFF,DEAF) AND DEAF<0,6),L-0.02,L-0.1,4,0),COLOR00FF00;
DRAWTEXT(FILTER(CROSS(DIFFF,DEAF) AND DEAF>0,13),H+0.25,'MACD下拐点'),COLORYELLOW;
STICKLINE(FILTER(CROSS(DIFFF,DEAF) AND DEAF>0,13),H+0.02,H+0.12,4,0),COLORBLUE;
DRAWTEXT(FILTER(CROSS(MACDD,0),13),L*0.65,'MACD上拐点'),COLORRED;
STICKLINE(FILTER(CROSS(MACDD,0),13),L*0.97,L*0.95,4,0),COLORWHITE;
ROC:=(CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*100;
DRAWTEXT(FILTER(CROSS(ROC,0),6),L-2.25,'骗线拐点'),COLORWHITE;
STICKLINE(FILTER(CROSS(ROC,0),6),L-0.02,L-0.15,4,0),COLORFF00FF;
我是用这个的

通达信统计当日主力资金进入多少的指标

买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:买/AMOUNT*100,COLORRED,NODRAW;
流入百万:AMOUNT*买%/100000000,COLORMAGENTA,NODRAW;
流出百万:(AMOUNT/1000000-流入百万)*-1,COLORGREEN,NODRAW;
净流百万:=流入百万+流出百万,COLORCYAN,NODRAW;
净流比:流入百万/流出百万*-1,COLORYELLOW,NODRAW;
流入换手:流入百万*10000/C/CAPITAL*100,NODRAW;
流出换手:流出百万*10000/C/CAPITAL*100,COLORCYAN,NODRAW;
净流入出:净流百万*10000/C/CAPITAL*100,COLORRED,NODRAW;
STICKLINE(流入换手>0,流入换手,0,2.3,0), COLORRED;
STICKLINE(流出换手<0,流出换手,0,2.3,0) ,COLORGREEN;

这是通达信主力力道指标,恳请高手将其改成预警公式或选股公式,以便能在第一个红柱出现时将其选出来...

什么狗屁公式啊。。。。天哪,一文不值

通达信怎样添加主力先锋指标公式

{主力先锋}

N:=7;

M:=5;

VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

B:=SMA(VAR1,N,1);

VAR2:=SMA(B,M,1);

STICKLINE(B>VAR2,B,VAR2,0.8,1),COLORRED;

STICKLINE(B<VAR2,B,VAR2,0.8,0),COLORGREEN;

MAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;

短高: 90,COLORGREEN;

高抛: 80,DOTLINE,COLORYELLOW;

MAR2:=LLV(LOW,34);

MAR3:=HHV(HIGH,34);

SK:=EMA((MAR1-MAR2)/(MAR3-MAR2)*100,13);

SD:=EMA(SK,3);

STICKLINE(SK<SD,SK,SD,0.8,0),COLORCYAN;

STICKLINE(SK>SD,SK,SD,0.8,1),COLORMAGENTA;

低吸: 20,DOTLINE,COLORYELLOW;

短底: 10,COLORRED;

中值:B,NODRAW;

短值:SK,NODRAW,COLORMAGENTA;

STICKLINE(SK>=90 OR B>=90,96,101,4,1),COLORYELLOW;

STICKLINE(B>=90 AND SK>=90,96,101,4,0),COLORYELLOW;

STICKLINE(SK<=10 OR B<=10,-1,4,4,1),COLORBLUE;

STICKLINE(B<=10 AND SK<=10,-1,4,4,0),COLORBLUE;

STICKLINE((SK<=10 OR B<=10) AND B>REF(B,1) AND SK>REF(SK,1),-1,4,4,1),COLOR7F00FF;

STICKLINE(B<=10 AND SK<=10 AND B>REF(B,1) AND SK>REF(SK,1),-1,4,4,0),COLOR7F00FF;

STICKLINE((SK>=90 OR B>=90) AND B<REF(B,1) AND SK<REF(SK,1),96,101,4,1),COLORWHITE;

STICKLINE(B>=90 AND SK>=90 AND B<REF(B,1) AND SK<REF(SK,1),96,101,4,0),COLORWHITE;


===================================

按下面图示操作即可

请高手给我把通达信主力控盘公式改成选出开始控盘的选股公式

VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
开始控盘:CROSS(控盘,0);
测试通过,
希望能够帮助你!

通达信 庄家抬轿做“有庄控盘”和“高度控盘”两个选股公式

VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
有庄控盘:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0);
VAR2:=100*WINNER(CLOSE*0.95);
高度控盘:=IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0);
REF(C,1)>REF(C,2) AND 有庄控盘 AND 高度控盘;